99 4x4 3.0L with DTCs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-02-06, 08:39 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 1
99 4x4 3.0L with DTCs

I have 3 DTCs, P0102 low MAF signal, P0171 and P0174 bank lean indicators. The truck has 77,500 miles on it. No obvious hose leaks. Occassional spells of rough idling, and occassional misfires although not reported in the codes. Until it warms up it can be require multiple starts or keeping your foot on the gas to keep it running. I will clean the MAF and do a detailed check of the hoses, any other ideas?

Can a bad tank of gas cause this? Or a can of injector cleaner?

Thanks

bfromcolo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-09-07, 11:49 AM
BigOz
 
Join Date: Jan 2007
Location: California
Posts: 2
biggrin Re: 99 4x4 3.0L with DTCs

My '95 3.0 Ranger started acting up at around 190,000 miles. Rough idle, smelly exhaust and transmission started shifting hard. The ODB-II code was P0102, which indicated something wrong with the mass airflow sensor. I sprayed the heck out of the MAF elements with electronic contact cleaner. That didn’t help. So I bought a rebuilt MAF unit from AutoZone ($103). My truck now runs perfect, as it always did.
I hope this helps.
ozzie.marquez is offline  
post #3 of 3 (permalink) Old 01-09-07, 01:14 PM
BigOz
 
Join Date: Jan 2007
Location: California
Posts: 2
biggrin Re: 99 4x4 3.0L with DTCs

My '95 3.0 Ranger started acting up at around 190,000 miles. Rough idle, smelly exhaust and transmission started shifting hard. The ODB-II code was P0102, which indicated something wrong with the mass airflow sensor. I sprayed the heck out of the MAF elements with electronic contact cleaner. That didn’t help. So I bought a rebuilt MAF unit from AutoZone ($103). My truck now runs perfect, as it always did.
I hope this helps.
ozzie.marquez is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome