99 automatic issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-03-05, 10:00 PM Thread Starter
Registered User
 
Join Date: Oct 2005
Posts: 1
99 automatic issues

Alright guys, I know one of ya'll can help me out here. I've gotten two different answers and it doesn't satisfy me. I bought my 99 auto with 54,000 miles bout 2 years ago. The day I drove it off the lot the man(being a friend of the family for years) flushed all my fluids in the truck. The truck shifts good and firm on a normal routine, but as the months are passing I'm noticing it likes to bow down at times. If persay I put the truck in drive and not accelerate, and I come to a stop at a red light and try to take off, the truck "growls" or whines in response to giving it gas and it doesn't want to shift out of first...I've noticed when taking off that it doesn't want to get above 20-30 miles an hour and I let off the gas and get on it again a little harder it'll finally shift real firm into second... Can anyone help me out on this issue? I've heard it may be the chip in the trans, or a censor on the motor going out. I've been warned I have maybe a month to go before the truck doesn't shift at all....HELP PLEASE?

Kiddo1387 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-16-05, 11:28 AM
Registered User
 
Join Date: Nov 2005
Posts: 42
roll Re: 99 automatic issues

Quote:
Originally Posted by Kiddo1387
Alright guys, I know one of ya'll can help me out here. I've gotten two different answers and it doesn't satisfy me. I bought my 99 auto with 54,000 miles bout 2 years ago. The day I drove it off the lot the man(being a friend of the family for years) flushed all my fluids in the truck. The truck shifts good and firm on a normal routine, but as the months are passing I'm noticing it likes to bow down at times. If persay I put the truck in drive and not accelerate, and I come to a stop at a red light and try to take off, the truck "growls" or whines in response to giving it gas and it doesn't want to shift out of first...I've noticed when taking off that it doesn't want to get above 20-30 miles an hour and I let off the gas and get on it again a little harder it'll finally shift real firm into second... Can anyone help me out on this issue? I've heard it may be the chip in the trans, or a censor on the motor going out. I've been warned I have maybe a month to go before the truck doesn't shift at all....HELP PLEASE?
This may or may not apply to your vehicle, but in researching my 98' Ranger , I found they have 2 types of transmission, 1 uses merconII fluid and the other uses merconV, these are not compatible and interchanging or mixing can cause damage. Just a place to start.
mtneer57 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome