99 Ranger A/C - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-16-07, 09:17 AM Thread Starter
Registered User
Join Date: May 2007
Location: KC
Posts: 10
99 Ranger A/C

I posted on here the other day, but some things have unfolded since.

Replaced the condensor & checked for leaks. Everything looked fine so charged the freon & pressure is OK. Have re-checked the pressure a few times over the past few days & is still good, so no leaks.

But the air blows hot. Thermometer shows it @ 100 degrees.

The clutch isn't engaging. All fuses seem to be ok, checked the relays & they seem to be ok too, but you can't check them like a regular fuse- I tried a new AC relay & no change.

Any ideas of what else to try before I look at replacing the compressor?
ejg593 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-16-07, 06:40 PM
Always the student
thefonz's Avatar
Join Date: Jul 2006
Posts: 1,737
Re: 99 Ranger A/C

Verify whether or not you have power to the compressor. No power, I definately would not replace it yet.
thefonz is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome