A4LD shifting problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-06-07, 07:11 PM Thread Starter
Registered User
Join Date: Nov 2007
Location: Michigan
Posts: 5
A4LD shifting problems

I have a 93 ranger stx with a 4.0L v6 and a stock A4LD tansmission
Recently I've had power loss and it won't shift from first to second until I let off the gas, I could get it up to the governed 6000 RPM's in first
shifting from then on is fine
And also my shifting rod will every once in a while will stick in drive (possobly others if I used them more) to the point where I have to go underneath and move the shifter multiply times to "unstick" it
Jacksniper64 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome