ABS Brake Problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-06-08, 07:49 PM Thread Starter
robs05xlt's Avatar
Join Date: Nov 2008
Location: LEBANON,PA.
Posts: 14
ABS Brake Problem?

Hi There:
Today we had our first snow.While driving in the neighbor hood streets & before getting into traffic. I applied the brakes hard to see how slick the roads are.I had the 4x4 ranger in 4h and slid about 25 or 30 ft. When I did this the brake pedal was pulsating. At the same time I heard this motor running from a low speed to a high speed repeatedly.When I released the brake the pulsating & motor stopped.This motor noise was coming from the rear of the truck. I took the truck out of 4w drive & there was no change using a hard brake & sliding. We then went to the food store at a slow pace in 4h & and no problem with normal brake applied and a little slide.My question is: Is the abs brake module bad or what? My warrenty is going to runout on the 16th of dec.Any advice will be greatly appreciated. used 05 ranger xlt,4x4,4dr.4.0 sohc ,6200 on the clock.
robs05xlt is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome