Bad code on cyl. #4 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-12-12, 02:53 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 5
Bad code on cyl. #4

I have been chasing a problem on my 96 4.0 Ranger. Autozone pulled a code of P0304, that's a problem with the # 4 cylinder. The engine runs rough when first started but after warming and driving it it seems to run just fine, but somewhat sluggish when trying to increase speed quickly.
I have replaced my spark plugs, fuel injectors and fuel filter. I am getting a spark when I ground out the #4 spark plug to a ground on the engine. I even tried a different plug wire with the same results. I also have tried chasing a possible vacume leak with starting fluid without any success.

-If it's a vacume leak why would it be to a specific cylinder?
-If its the injector after i replaced all six then why still #4?
-Electrical spark issue? Is the spark not strong enough? Need new coil?

Can anyone give me some directions to investigate, before I decide to take it to a shop

photocliff is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-12-12, 03:06 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,808
Re: Bad code on cyl. #4

Checked the compression on that cyl ?
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 11-13-12, 08:32 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 5
Re: Bad code on cyl. #4

Quote:
Originally Posted by R.S.LOGAN View Post
Checked the compression on that cyl ?
Would a low compression set off the computer error for that cylinder?
photocliff is offline  
post #4 of 4 (permalink) Old 11-14-12, 03:43 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,808
Re: Bad code on cyl. #4

If the compression is low on that cyl. for whatever reason that would cause engine to run rough and have a flat spot / drop in performance .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome