bad idle, backfire after wash - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-08-2011, 14:32   #1 (permalink)
Registered User
 
Join Date: Aug 2011
Posts: 2
bad idle, backfire after wash

I cleaned my engine compartment with simple green, a rag and water hose. The ne,t day I had rough idle and blinking check engine. Since I had to work, I parked it and fook car. The next week and a half it ran like it did when I bought it. Today it backfire under cruise load, it shimmy at idle and shimmy harder at accelerate from stop. nd blinking check engine light again. I am thinking spark problem somewhere, but where a week later? Could i have fried something when I moved it after cleaning?
PepsiBlueTRK is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-09-2011, 20:30   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,817
Re: bad idle, backfire after wash

What year and engine?
__________________
Bert
Bert is offline   Reply With Quote
Old 08-10-2011, 05:44   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,875
Re: bad idle, backfire after wash

Sounds like condensation / dampness on ignition set up . Depending on whats fitted on your model , check coil pack , ignition leads , ignition coils .
R.S.LOGAN is offline   Reply With Quote
Old 08-13-2011, 12:42   #4 (permalink)
Registered User
 
Join Date: Aug 2011
Posts: 2
Re: bad idle, backfire after wash

Sorry, i been away. It is 2003 6cyl 3L flex. It was heat of dat when the symptoms came on my drive to work. But that night, on way home it purred like new and has since without any maintenance. I'm thinking condensation somewhere that finally dried up.??
PepsiBlueTRK is offline   Reply With Quote
Old 08-22-2011, 20:30   #5 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,817
Re: bad idle, backfire after wash

Quote:
Originally Posted by PepsiBlueTRK View Post
Sorry, i been away. It is 2003 6cyl 3L flex. It was heat of dat when the symptoms came on my drive to work. But that night, on way home it purred like new and has since without any maintenance. I'm thinking condensation somewhere that finally dried up.??
I think you're right.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:06.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.