A/C Problem??? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-11-03, 10:03 PM
Posts: n/a
A/C Problem???

Have a '97 Ranger Supercab w/ 3.0 V6. Has a FS10 A/C system. Problem is my cooling fan turns on at any given time, but usually when the A/C is on. It also turns on a lot when the outside air temp is hot or during start up. When it does it at start up, it'll go away if I bring the RPM's up. When it's hot or the A/C is on, it just about never goes off. I changed the cooling fan/clutch but it still comes on. I was thinking it was the A/C compressor clutch. When this first started, I would turn on the A/C and the clutch would turn on and off about every second and nearly stall the motor. Now it just slams the cooling fan on. Does anybody know if it's the clutch, relay switch or ???

Oh yeah, when I turn the A/C to normal operation, it doesn't work. It just throws out REALLY hot air and it doesn't seem like the clutch tries to engage at all. It works perfectly when on the MAX A/C setting, except for the cooling fan thing.
Sponsored Links
post #2 of 3 (permalink) Old 09-12-03, 07:05 AM
Registered User
big1's Avatar
Join Date: Mar 2003
Location: Valley Station , Kentucky
Posts: 484
Re: A/C Problem???

Can I assume that your talking about a manual fan and not an electric?

When in doubt :DON'T
Valley Station, Kentucky
Dream EXPression Racing
big1 is offline  
post #3 of 3 (permalink) Old 09-12-03, 07:03 PM
Posts: n/a
A/C Problem?

Yeah, it's a manual. It has a viscous clutch. Thanks
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
EA CFI 3sp auto (1989): Problem with idle return sambulance Inline 6 Tech 4 08-09-03 05:06 AM
95 CV engine problem 95CV Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 9 04-22-03 09:17 PM
Acceleration problem and poor gas mileage mears Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 3 02-21-03 11:48 AM
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-02 10:39 PM
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-02 07:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome