CEL with Idle issue. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-02-08, 09:36 AM Thread Starter
Isuzu Guru.
88SuperTrooper's Avatar
Join Date: Oct 2007
Location: Wyoming
Posts: 4
CEL with Idle issue.

2003 Ranger XLT 2WD 4.0L V6: CEL light is on and has a slight idle issue. Doesnt stall, just idles kinda rough, and sometimes the CEL flashes on and off very quickly. Truck has: 6 New Injector's, 2 new Cat's, O2 Sensors, Fuel Filter. and some other new parts. I did not do the work, the FORD dealer here did. They have no Idea what is causing it. I just bought the Truck off a very good friend who needed the cash for a new 4WD 2004 Ford F-150 with 26K miles. It never stalls, above 2400 RPM you dont even feel the idle issue and runs good. I would like to figure it out, and get it fixed. We both figured that FORD would at least have gotten close to it, but they just want to keep throwing parts at it and never solving the problem. I do know its a "Flex Fuel" motor, Can be Run on E85 or Regular Gas.

Any Ideas would be great, This is the First Ford I have owned and I like it, the seats are soooo comfortable for my Back.. Loving it. Thanks Guys. hoping its a vacuum line that is routed wrong.

03' Ranger XLT 2WD.
4.0L V6.
Belltech Lowering Kit.
Gibson Exhaust.
Euro Tails.
20" wheels w/ 255-35-20 Tires.
Hunter Certified Alignment Tech.
Isuzu Guru.
88SuperTrooper is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome