check engine - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-25-2008, 12:55   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 2
99 2.5cyl check engine

I have a 4cyl automatic 99 Ford Ranger. I bought it a few weeks ago and it runs great. I live in southern Mississippi in case you would like to know the weather my truck operates in. The check engine light was on when I purchased it and still is. Sometimes when I start it the check guage light comes on as well, and my oil pressure guage doesnt read. after a couple of minutes it jumps up to the ideal running pressure and off goes the check guage light. I took it to Autozone for a diagnostics test but the machine read nothing. (by nothing i mean it did not respond when connected) the only other thing i have noted is that sometimes the engine turns over a few more times than I consider average before it fires up. after that, all is well. Any ideas? feedback is greatly appreciated
mnunes810 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-03-2009, 06:57   #2 (permalink)
Registered User
 
Join Date: Aug 2008
Location: Black Hawk SD
Posts: 6
Re: check engine

If the check engine light is on then you have a code. The people at Autozone don't know how to diagnose vehicles, they sell parts. If you don't have a scan tool yourself take the truck to a repair shop.
dnold is offline   Reply With Quote
Old 01-10-2009, 13:38   #3 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 2
Re: check engine

it is not that i am relying on the know how of my discount part store employees, the problem is that their code reader will not link up to my data connect. i checked the fuse, its there, still nothing. my check guage light comes on periodically as well on cold starts and goes off after a few minutes. my fuel economy is less than ideal, 17+/- which seems poor for the 2.5 4 cyl.
mnunes810 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:57.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.