clutch problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-06-2005, 16:34   #1 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 1
clutch problems

i got a 93 ranger with a 4.0 and my clutch will not depress any body ever heard of this if so let me no wat you think it might be thanks
joshflow47 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-15-2005, 14:46   #2 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 49
Re: clutch problems

Have you checked your clutch fluid? Is the pettle adjusted right? Cuz that is odd.
MadModderModa is offline   Reply With Quote
Old 12-16-2005, 14:16   #3 (permalink)
GI Jon
 
gijon's Avatar
 
Join Date: Dec 2005
Location: Michigan
Posts: 4
Re: clutch problems

Quote:
Originally Posted by MadModderModa
Have you checked your clutch fluid? Is the pettle adjusted right? Cuz that is odd.
pettle?
gijon is offline   Reply With Quote
Old 12-18-2005, 19:52   #4 (permalink)
Randy Williams
 
Join Date: Nov 2005
Location: Port Huron, MI
Age: 30
Posts: 63
Re: clutch problems

if there was any fluid anywhere, check the hose coming from your slave cylinder going into the tranny. mine popped out one time, and i had no idea what was wrong. i got pissed and thought maybe my pedal was stuck or something, and bent the shit out of them peddle. prolly just your fluid though

by the way, do 93 rangers have cable clutches, or hydraulic? no idea, so sorry if i gave that info for no reason.
95RANGER351 is offline   Reply With Quote
Old 12-20-2005, 18:13   #5 (permalink)
GI Jon
 
gijon's Avatar
 
Join Date: Dec 2005
Location: Michigan
Posts: 4
Re: clutch problems

Quote:
Originally Posted by 95RANGER351
if there was any fluid anywhere, check the hose coming from your slave cylinder going into the tranny. mine popped out one time, and i had no idea what was wrong. i got pissed and thought maybe my pedal was stuck or something, and bent the shit out of them peddle. prolly just your fluid though

by the way, do 93 rangers have cable clutches, or hydraulic? no idea, so sorry if i gave that info for no reason.
hydraulic
gijon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:12.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.