it died? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-09-07, 08:16 PM Thread Starter
Registered User
Join Date: Oct 2007
Posts: 22
Question it died?

just replaced ignition control mod and the truck was running great,then it just died?.got gas spark,atains partial ignition but doesnt take nuff gas to keep going?
treeguy is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-03-08, 07:15 PM
Registered User
Join Date: Oct 2008
Posts: 25
Re: it died?

I have a 1998 XLT with a 2.5,5speed manual,2 wheel drive. I'm having a similar problem.The truck was running fine,and all of a sudden started losing power as if out of gas. THe fuel pump is engaging,It's definietly not out of gas,I'm getting fuel to the fuel rail,spark at all plugs,yet she refuses to fire up. If I spry starter fluid she'll fire up. Checed all injectors with a noid lite,and all check out fine. I'm having a hell of a time getting to the core of the problem here.If by chance you come across a solution to this madness,I sure would appreciate if you could shoot me an email to :
And I'll be happy to do the same.In the meantime good luck with your truck.
scshane367 is offline  
post #3 of 3 (permalink) Old 11-15-08, 07:48 PM
robs05xlt's Avatar
Join Date: Nov 2008
Location: LEBANON,PA.
Posts: 14
Re: it died?

Hi There:
I was wondering why you changed the ignition module when the truck was running good? Ignition modules are only replaced when they are bad.They either provide spark or they do not. They do not get weak.Did you drop the module at install? Did you coat the back with dielectric grease?
If you leave up on the gas pedal does the engine run smoother?If it does I would change the fuel filter.
robs05xlt is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome