Electrical Problems....Help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-14-04, 05:03 PM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 3
Electrical Problems....Help

I was driving home last night and my speedometer and whipers just quit working. This morning the power windows didn't work either. What could be causing all of these problems?

Thanks.

gitrdun is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-14-04, 05:07 PM
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 45
Posts: 3,838
Re: Electrical Problems....Help

Stupid question - checked the fuses ?, and does it still start ?

I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline  
post #3 of 6 (permalink) Old 01-14-04, 05:11 PM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 3
Re: Electrical Problems....Help

Yes, it starts and yes, I checked the fuses. Everything else seems to be working...even the tach! The turn signal is on the same knob as the whiper controll and the signals work. Also the door ajar light comes sometimes when the doors are shut.

Last edited by gitrdun; 01-14-04 at 05:17 PM.
gitrdun is offline  
post #4 of 6 (permalink) Old 01-14-04, 05:15 PM
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 45
Posts: 3,838
Re: Electrical Problems....Help

So lights are on but nobody home, sounds like computer failing....

What car model, year etc is giving you the trouble

Jason

I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline  
post #5 of 6 (permalink) Old 01-14-04, 05:18 PM Thread Starter
Registered User
 
Join Date: Jan 2004
Posts: 3
Re: Electrical Problems....Help

2000 Ford Ranger XLT 4X4 w/ V6
gitrdun is offline  
post #6 of 6 (permalink) Old 01-14-04, 05:20 PM
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 45
Posts: 3,838
Re: Electrical Problems....Help

EARTH wire, and more than likely for the computer is the problem, or possibly earth from battery to car body, check out those places, and any other earth wires you can find.

Clean the battery terminals and check them out.

Jason

I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'98 Escort electrical problems Capone Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 3 02-18-04 11:21 AM
1993 XLT - Electrical Problems piranicon Ford Bronco Forum 9 01-04-04 07:16 PM
F-250 electrical problems Rocketattack Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel 5 09-24-03 06:52 PM
electrical problems craigant Interior | Electrical | ECU 4 09-01-03 02:58 AM
XR6T Electrical problems Lightning Interior | Electrical | ECU 2 06-02-03 05:39 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome