Engine died while running - 97 Ranger - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-02-2009, 22:00   #1 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 1
Engine died while running - 97 Ranger

I was driving my '97 Ranger (2.3L, 4-cylinder, automatic) on the interstate, and the engine just lost power. I couldn't accelerate or keep my speed, so I coasted to stop on the shoulder. I tried to start it later a few times but it wouldn't start (it only kind of started just once--it seemed to be at half power, then it died again 10 seconds later). It should still have just under half a tank of gas. Does this sound like a battery or an alternator problem? I just changed the battery three weeks ago. I still had my headlights and my interior lights.

I greatly appreciate help.

Thanks,
Chris
deuce1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-04-2009, 01:27   #2 (permalink)
Registered User
 
Join Date: Sep 2008
Posts: 72
Re: Engine died while running - 97 Ranger

I would suspect the electronic engine system instead. Possible causes: throttle position sensor? fuel pressure regulator? or possibly even fuel pump.....
jimbot58 is offline   Reply With Quote
Old 02-04-2009, 05:51   #3 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,709
Re: Engine died while running - 97 Ranger

Check the timing/timing belt.
thefonz is offline   Reply With Quote
Old 08-07-2009, 19:28   #4 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 25
Re: Engine died while running - 97 Ranger

I had the same problem. Everything I've checked so far checks out fine so far. eg: fuel, fuel pressure,spark etc... My next step soon as I find the time is to check
the timming belt. I would be more than happy to let you know what I find out. And if you would be as kind to let me know if you come across what your problem is I sure would appreciate it.
You can reach me via email at scshane367@yahoo.com
scshane367 is offline   Reply With Quote
Old 08-09-2009, 05:46   #5 (permalink)
Registered User
 
Join Date: Jul 2009
Posts: 18
Re: Engine died while running - 97 Ranger

Have you checked for spark? If you have spark spray a continuous stream of throttle body cleaner as someone turns the key. If you have spark it should run, it might be ruff but it should go. If it does then work your fuel system. If you don't have spark let us know.
94ranger is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:58.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.