Engine No Power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-07-10, 08:14 AM Thread Starter
Registered User
 
Join Date: Apr 2010
Posts: 2
Engine No Power

Hello,

I have a Mazda B4000 and from a few months I saw me as the power of the engine decrease. I have much less power when the engine is on load. I also notice that the relationship speed/rpm is not the same. At first, in 2000 rpm, I drove 110 km / h and now at 2,000 rpm , I drive 90 km / h. Even if the check engine light does not turn on, I suspect the MAF to be responsible. What do you think?

Thanks, any help would be appreciated Vincent

Vynce is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-07-10, 10:42 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: Engine No Power

It sounds like it's not shifting into overdrive. It could be the MAF not giving the correct signal to shift. What year is it? Is it an automatic?

Bert
Bert is offline  
post #3 of 4 (permalink) Old 04-07-10, 10:51 AM Thread Starter
Registered User
 
Join Date: Apr 2010
Posts: 2
Re: Engine No Power

Thanks for you answers,

It's a 1994, manual transmission.
Vynce is offline  
post #4 of 4 (permalink) Old 04-10-10, 11:55 AM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: Engine No Power

I find the rpm change with a manual transmission a bit odd. What's the mileage on the truck? Have you changed the transmission fluid at all?

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome