Exhaust problem??? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-02-05, 01:48 PM Thread Starter
Registered User
 
Join Date: Dec 2005
Posts: 1
confused Exhaust problem???

I was driving my ranger at 50 mph,on level road when I heard a slight snap or pop and the truck lost power. The engine remained running but the truck would not go above 25-30 mph. My usual shop has had the truck for a week and can't find the problem. There is no DTC displayed when scanned and no check engine light. I suspect a clogged cat, muffler or collapsed pipe, but the shop manager does not want to believe this could be. Anyone else experienced this problem? Thanks for any help.

Last edited by Dave W.; 12-02-05 at 02:55 PM. Reason: error
Dave W. is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-02-05, 02:21 PM
Registered User
 
garth04's Avatar
 
Join Date: Sep 2005
Location: Adelaide
Posts: 114
Re: Exhaust problem???

If your usual shop has had the vehicle for a week and can't find the problem, I would be changing shops. Any place that takes longer than 2 days to diagnose a problem is ripping you off.

The symptoms sound like restricted exhaust, and I have seen a cats break up and block exhaust systems, might have been the pop you heard.

Speed Costs Money
How Much Do You Want To Spend?
garth04 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome