Grinding at start up? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-15-05, 02:38 PM Thread Starter
Registered User
Join Date: Dec 2005
Posts: 49
Grinding at start up?

Hey every one, I have an 88 ranger with a 2liter in it. Now its cold out and my electronic choke dosnt work ( I know that), when the engien turns over to run something is making a grinding sound, and it only dose it right when the engien starts. I think its the starter, cuz the engien purrs like a kitten. Any one have any thoughts? Starter not disengauging fully when enigen starts (indicating that the starter is dieing), battery not have enough cranking amps? If you need more details just ask.
MadModderModa is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome