HELP!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-06-2013, 07:50   #1 (permalink)
Registered User
 
Join Date: Apr 2013
Posts: 19
Exclamation HELP!!!!

I've got a 1996 3.0L that started losing coolant. No leaks, no water in the oil. So I decided to check the heater core. After getting everything back in, the engine idles real rough and has some backfire to it. I put new plugs and wires on it with no improvement. I had the battery cable off for several days. Could it have wiped something out when I hooked the battery back up? I see nothing wrong with the wiring or vacuum lines. HELP!!!
Goldeneagle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-06-2013, 08:08   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,847
Re: HELP!!!!

Could still be head gasket and water passing out the exhaust rather than mixing with the oil , dependant on where gasket blown. Especially if cooling system pressurising .
R.S.LOGAN is offline   Reply With Quote
Old 05-06-2013, 08:19   #3 (permalink)
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: HELP!!!!

It was running fine before I started, just losing coolant. I'm just trying to get it back to running right for now. The exhaust is where I figure the coolant is going.
Goldeneagle is offline   Reply With Quote
Old 05-06-2013, 08:43   #4 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,847
Re: HELP!!!!

Carry out a block test and that will confirm or not , simple test .
R.S.LOGAN is offline   Reply With Quote
Old 05-06-2013, 10:18   #5 (permalink)
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: HELP!!!!

Also, what is the module lookin thing inside the cab behind the passenger kick panel?
Goldeneagle is offline   Reply With Quote
Old 05-09-2013, 17:25   #6 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,848
Re: HELP!!!!

I think you found the PCM
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:25.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.