HELP!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-06-13, 07:50 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Exclamation HELP!!!!

I've got a 1996 3.0L that started losing coolant. No leaks, no water in the oil. So I decided to check the heater core. After getting everything back in, the engine idles real rough and has some backfire to it. I put new plugs and wires on it with no improvement. I had the battery cable off for several days. Could it have wiped something out when I hooked the battery back up? I see nothing wrong with the wiring or vacuum lines. HELP!!!

Goldeneagle is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-06-13, 08:08 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,897
Re: HELP!!!!

Could still be head gasket and water passing out the exhaust rather than mixing with the oil , dependant on where gasket blown. Especially if cooling system pressurising .
R.S.LOGAN is offline  
post #3 of 6 (permalink) Old 05-06-13, 08:19 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: HELP!!!!

It was running fine before I started, just losing coolant. I'm just trying to get it back to running right for now. The exhaust is where I figure the coolant is going.
Goldeneagle is offline  
post #4 of 6 (permalink) Old 05-06-13, 08:43 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,897
Re: HELP!!!!

Carry out a block test and that will confirm or not , simple test .
R.S.LOGAN is offline  
post #5 of 6 (permalink) Old 05-06-13, 10:18 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: HELP!!!!

Also, what is the module lookin thing inside the cab behind the passenger kick panel?
Goldeneagle is offline  
post #6 of 6 (permalink) Old 05-09-13, 05:25 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,930
Re: HELP!!!!

I think you found the PCM

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome