help please - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-11-09, 02:00 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 3
help please

hey guys i am new to the forum but i figured i would tell yall what my problem is and see if you guys could help..

i have never really messed with an 8.8 ford..just always 9 inch fords or chevy 12 bolts..well here is the deal..i bought an 8.8 from a friend out of an older ranger..it is 28 spline and has a posi unit in it..the axles are 25 3/4 and the other 28 3/4..well i am taking the posi out and putting a mini spool in it which means i need an open carrier..well i bought one and the bearings were to big for it..so idk what to do now..can you guys tell me where to look to find one..and did i buy the wrong one? guy said it was 8.8 open carrier..could it be a 7.5 carrier? any help is greatly appreciated..thanks
dragracer9102 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-11-09, 02:01 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 3
Re: help please

by the way the ranger was 4x4..and the lenghts of the axles i put is to the end of the splines..thanks
dragracer9102 is offline  
post #3 of 3 (permalink) Old 03-11-09, 04:04 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 3
Re: help please

nvmd guys..i think i have figured out my problem
dragracer9102 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome