!!HELP!! Speedometer in 99 Ranger not working... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-23-2005, 22:32   #1 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 3
!!HELP!! Speedometer in 99 Ranger not working...

HI Everyone. My name is Israel and am in San Antonio, TX I drive a '99 Ford Ranger 6 cyl and my speedometer is not working and the ABS light and check Engine light are on. Does anyone know how to fix this and will it cost a lot of money? Also since the speedometer is not working...the odometer is not working nor is the cruise control...due to the speed meter not working. Someone please help.
learsi1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-29-2005, 11:51   #2 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 3
Re: !!HELP!! Speedometer in 99 Ranger not working...

Quote:
Originally Posted by learsi1
HI Everyone. My name is Israel and am in San Antonio, TX I drive a '99 Ford Ranger 6 cyl and my speedometer is not working and the ABS light and check Engine light are on. Does anyone know how to fix this and will it cost a lot of money? Also since the speedometer is not working...the odometer is not working nor is the cruise control...due to the speed meter not working. Someone please help.
Hey there, I had the same problem on my '99 Ford Ranger XLT. I woiuld guess that you have a bad speed sensor. The next question you are going to have is do you have two or four wheel drive? I have two wheel drive so it was a little bit of a pain getting the correct part. The speed sensor is on the top of the rear axle in the 2wd models and is actually really easy to remove and replace. Took me all of 30 minutes to roll under my truck, take the part off, put the new one on and roll out. If I had put my ratchet set closer to where I was working, it would have been faster.
99rangerXLT is offline   Reply With Quote
Old 09-01-2005, 16:01   #3 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 3
Re: !!HELP!! Speedometer in 99 Ranger not working...

Thanks man I appreciate that very much...in times when gas is out of hand...saving money doing the job yourself ...HELPS. I greatly appreciate and I do have a 2wd XLT Sport. By the way...I will keep the tools next to me. I will tell you how long it takes to get done.

Quote:
Originally Posted by 99rangerXLT
Hey there, I had the same problem on my '99 Ford Ranger XLT. I woiuld guess that you have a bad speed sensor. The next question you are going to have is do you have two or four wheel drive? I have two wheel drive so it was a little bit of a pain getting the correct part. The speed sensor is on the top of the rear axle in the 2wd models and is actually really easy to remove and replace. Took me all of 30 minutes to roll under my truck, take the part off, put the new one on and roll out. If I had put my ratchet set closer to where I was working, it would have been faster.
learsi1 is offline   Reply With Quote
Old 09-11-2005, 11:45   #4 (permalink)
Registered User
 
Join Date: Oct 2004
Age: 33
Posts: 2
Re: !!HELP!! Speedometer in 99 Ranger not working...

I have the same issue..ABS light on, and the speedo is not working...I'll keep yall posted if its the same fix :)

Chad
scheister is offline   Reply With Quote
Old 09-24-2005, 19:27   #5 (permalink)
Registered User
 
Join Date: Aug 2005
Posts: 3
Re: !!HELP!! Speedometer in 99 Ranger not working...

Quote:
Originally Posted by scheister
I have the same issue..ABS light on, and the speedo is not working...I'll keep yall posted if its the same fix :)

Chad
Thanks Chad...yeah my lights are on (ABS & Check engine) I still need to replace it and now that I know how I can get to it...just need the time.
learsi1 is offline   Reply With Quote
Old 10-21-2005, 09:47   #6 (permalink)
Registered User
 
Join Date: Oct 2005
Posts: 2
Re: !!HELP!! Speedometer in 99 Ranger not working...

Quote:
Originally Posted by learsi1
HI Everyone. My name is Israel and am in San Antonio, TX I drive a '99 Ford Ranger 6 cyl and my speedometer is not working and the ABS light and check Engine light are on. Does anyone know how to fix this and will it cost a lot of money? Also since the speedometer is not working...the odometer is not working nor is the cruise control...due to the speed meter not working. Someone please help.
i am not positive but it could be that your alternator is going out.
mikeford1984 is offline   Reply With Quote
Old 11-16-2005, 14:53   #7 (permalink)
Registered User
 
Join Date: Nov 2005
Posts: 1
confused Re: !!HELP!! Speedometer in 99 Ranger not working...

Have the same probllem but have a 2wd, 6cl, 2000. Replaced the top sensor and still have the problem? Is there another sensor cause it is dead till I hit obout 80 and then starts to work or jump around from 70 to 80. Any help would be appriciated
gman67487 is offline   Reply With Quote
Old 11-16-2005, 20:13   #8 (permalink)
93 2.3 MTX BOLTED OUT!
 
Cronicus's Avatar
 
Join Date: Sep 2005
Location: in my car pretty much
Age: 28
Posts: 626
Re: !!HELP!! Speedometer in 99 Ranger not working...

ive got a 93 2.3.
the year is a big jump form a 99 but heres my 2 cents
i snaped the rear transaxle mount bolt clean in half the first time i fed my engine oxygen injection "like nos"
when this happened the rear end of engine droped and drug on the glasspack
coming right of the ex manafold
which saved everything else but, i yanked the spedo cable to hell.
i replaced my ensor switc which is at the tranny.
no luck the guys at tranco said the problems in the dash which needs to be removed.
so i gave up on it after seeing there estimates and considering the $ could be used betetr elsewhere like
runing a digital spedo i got from autozone, with ododmitor and a digital rpm gauge/scantool, all for less thna what it cost to fix the problem, just disconected the sensor to the old spedomitor, and cured the light.
sumtimes u gota think outside the box
Cronicus is offline   Reply With Quote
Old 11-09-2006, 10:15   #9 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 2
Lightbulb Re: !!HELP!! Speedometer in 99 Ranger not working...

OK, I'm comming really late to this thread, but I thought I'd add my 2cents..


I've got a 99 Mazda B2500, which as we all know is just a Ranger with a Mazda logo...

At anyrate, I recently had the same problem with my speedometer suddenly failing. After some quick forum searching I found that the ABS sensor in the rear-differential is what also drives the speedometer in the dash.

I checked the local parts dealers, and found that Napa had the replacement part for about $12. DO NOT BUY THIS PART FROM THE DEALER, they wanted to charge me $80 or something.

At any rate, its 1 bolt on the top of the axle that holds this in place, and a pigtail for the wiring assembly, I couldn't get my camera in at the right angle, but its REALLY easy to replace...

just wanted to add a bit, thanks

joey
jofficer is offline   Reply With Quote
Old 05-12-2007, 09:08   #10 (permalink)
smg
Registered User
 
Join Date: May 2007
Posts: 2
Re: !!HELP!! Speedometer in 99 Ranger not working...

I too have this issue - speedo jumps around and stops working for a while, Odo also stops working, ABS light on, Check Engine light on. 99 Ranger, 4cyl, 5spd, XL, Regular cab w/84k Miles. I replaced the speed sensor (purchased from a Ford dealer) and the problem was not resolved. Any other ideas?
smg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:18.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.