help! upper control arm driving me nuts! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-09-2006, 16:57   #1 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 4
help! upper control arm driving me nuts!

i replaced the uper contrl arm because the ball joint was going out but now the joints where it connects to the frame are squeeking and knocking. i'll drive around a while with it alright, it'll start with the noise, i'll tighten it up and it disappears but it starts up again. is something wrong with these things or am i just not tightening it up enough? anyone have the same problem and know how to fix it?
goatmonkey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2006, 19:40   #2 (permalink)
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Re: help! upper control arm driving me nuts!

Quote:
Originally Posted by goatmonkey
i replaced the uper contrl arm because the ball joint was going out but now the joints where it connects to the frame are squeeking and knocking. i'll drive around a while with it alright, it'll start with the noise, i'll tighten it up and it disappears but it starts up again. is something wrong with these things or am i just not tightening it up enough? anyone have the same problem and know how to fix it?
tighten until the spring washed under the nut deforms and goes flat and then add some... if it comes loose again pop the threads .
atec77 is offline   Reply With Quote
Old 07-11-2006, 12:46   #3 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 4
Re: help! upper control arm driving me nuts!

there's no washers, at least nothing that looks like it should deform. what do you mean by pop the threads?
goatmonkey is offline   Reply With Quote
Old 07-20-2006, 11:43   #4 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 23
Re: help! upper control arm driving me nuts!

Quote:
Originally Posted by goatmonkey
there's no washers, at least nothing that looks like it should deform. what do you mean by pop the threads?
Don't understand the pop the threads deal either?!??

Look at the manual and make sure that you're not missing a lock washer or something in there. Also when you re-assemble suspension, you should fully assemble it (leaving the bushing bolts slightly loose), set it on the tires, bounce the suspension a couple times and then fully tighten all the bushing bolts!!! They maybe be binding up due to this preload and loosening the bolts. A little BLue Loctite goes a long way too.
Natedog is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:51.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.