High RPM's at start up? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-05-13, 06:46 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Question High RPM's at start up?

When I start my '96 3.0 up, it revs up to about 2000rpm and takes a little while to idle down. Even in this wonderfull Texas 100 deg. weather. Any ideas?

Goldeneagle is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-05-13, 10:09 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,816
Re: High RPM's at start up?

Could be wrong but would think it would be normal till engine heats up evven with outside temp.
R.S.LOGAN is offline  
post #3 of 7 (permalink) Old 08-05-13, 06:53 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,907
Re: High RPM's at start up?

About how long is a little while?

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
post #4 of 7 (permalink) Old 08-06-13, 05:56 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: High RPM's at start up?

Quote:
Originally Posted by CatSkinner View Post
About how long is a little while?
About 2 minutes. Seems like a long time in 100deg weather.
Goldeneagle is offline  
post #5 of 7 (permalink) Old 08-06-13, 03:25 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,907
Re: High RPM's at start up?

Yeah, seems too long to me,too. Are the cooling fans kicking in right away, or are they idle until your up to temp? And are you starting it with the AC running?

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?

Last edited by CatSkinner; 08-06-13 at 03:26 PM. Reason: Thunk of something else
CatSkinner is offline  
post #6 of 7 (permalink) Old 08-07-13, 04:33 AM Thread Starter
Registered User
 
Join Date: Apr 2013
Posts: 19
Re: High RPM's at start up?

Fan runs off the water pump. No a/c when I start it. Recon it is the IAC acting up?
Goldeneagle is offline  
post #7 of 7 (permalink) Old 08-07-13, 06:29 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,907
Re: High RPM's at start up?

I'd start by cleaning that.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome