I just got My first Truck!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-29-2007, 11:43   #1 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 5
I just got My first Truck!!

Hi everyone. I'm 16 and I just purchased my first vehicle ever. I bought a 1996 Ford Ranger. It's a low rider, with sunroof, neon lights in the floor board, neon flames dashboard that moves to the bass, and I also just put a Sony Eplode CD system. It seems to be an awesome truck, I haven't gotten to drive it past our driveway cause I haven't gotten it insured yet. I payed also only payed $900 for it. It seemed like an awesoem deal. I'll post pics and see what you all think. I just want some advice cause this is my first truck and I don't know much about them. I race Motocross and I rebuild all my motors, but I know automobiles are much different. Well here it is.




FORD#740MX'ER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-30-2007, 22:31   #2 (permalink)
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: I just got My first Truck!!

congrats, personally i am not one for lowered trucks. but it looks clean. it looks just low enough. in my opinion some times people get too silly with how low they lower their truck.

any way just a word of advice 95-07 3.0 rangers have a few hiccups to look into infixing
first if you have a 3.0 then you might want to get to the cam position sensor changed out, then after that every 70,000 miles. because when it goes out the oil pressure goes also and the perfectly good engine goes also. also if you have a Manuel transmission, the shift rail plugs like to leak on rangers and if it leaks too much fluid the transmission will seize on you. but the fix is easy.

the 2.4q just need timing belts changed but i forget intervals. and i dont know 4.0s flaws

but if you take care of your truck and keep maintenance regular it wont bite you.
mre_power is offline   Reply With Quote
Old 08-30-2007, 22:45   #3 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 2
Re: I just got My first Truck!!

looks good buddy
if you like it,thats what matters
BIGDAVE123 is offline   Reply With Quote
Old 09-10-2007, 21:28   #4 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 5
Re: I just got My first Truck!!

I love this truck. I finally got the title changed and is now in my name, insured and I got my license and I drive it to work school and everywhere else. Me and my grandpa had to get new leaf springs due to the idiots who had it before me. So I bought new hubs, brakes and whole brake assembly, leaf springs, U-joints, leaf hangers, new bed bolts, and applied rustolium to frame after a good sanding. It now sits about 3 inches higher in the rear. Now I have another problem that has occured. The retarded previous owners also put smaller tires on the front and bigger on the rear. The rear has (225's) and I can't remember the front. But they are really thin. But anyways. I'm putting new tires on it this pay day (Wednesday). I'm going to get much more meatier tires on it. Anyways the problem which I've come across is right when I hit 55mph it starts to get a headshake (horrible tire vibrations in front right wheel. Well I've inspected somewhat, but have'nt had the the time for a full observation. Can you all please point me in the right direction to what might cause this??? It's kinda scary goin down the road and knowing your wheel might fall off. Could it be bearings causing this???? I can't drive on the interstate till this is fixed due to the wheel hop being so bad. Ohh and it's really, really rough if I hit just a small lip in the road on the right side. It almost throws me out of control. I could really use some help. Thanks in advance everyone.
FORD#740MX'ER is offline   Reply With Quote
Old 09-11-2007, 05:56   #5 (permalink)
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: I just got My first Truck!!

might be bad or unballanced tire. usually are
mre_power is offline   Reply With Quote
Old 09-11-2007, 17:41   #6 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 5
Re: I just got My first Truck!!

Quote:
Originally Posted by mre_power
might be bad or unballanced tire. usually are
That's what I was thinking. I see a slight buldge in the tire that is wobling. So I'm going tomorrow after school to put a set of tires on it.
FORD#740MX'ER is offline   Reply With Quote
Old 09-12-2007, 16:31   #7 (permalink)
Registered User
 
Join Date: Jul 2007
Location: Sacramento, CA
Posts: 12
Re: I just got My first Truck!!

Quote:
Originally Posted by FORD#740MX'ER
That's what I was thinking. I see a slight buldge in the tire that is wobling. So I'm going tomorrow after school to put a set of tires on it.

Bulge is bad news. Tire separation; just dealt with that on my car. Replace ASAP, they can blow on you.
stircrazy is offline   Reply With Quote
Old 09-12-2007, 16:51   #8 (permalink)
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: I just got My first Truck!!

Quote:
Originally Posted by stircrazy
Bulge is bad news. Tire separation; just dealt with that on my car. Replace ASAP, they can blow on you.
yeah had one happen while i was on th interstate a few years ago. my truck then wanted to spin around at 45 mph with it
mre_power is offline   Reply With Quote
Old 09-12-2007, 18:17   #9 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 5
Re: I just got My first Truck!!

Ewww not good. Well I went to the tire shop and I have to wait till tomorrow morning cause the shipment hadn't come in yet. Owell
FORD#740MX'ER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.