loud scraping noise 03 ranger - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-01-08, 01:42 AM Thread Starter
Registered User
 
Join Date: Aug 2008
Posts: 2
confused loud scraping noise 03 ranger

today while driving my ranger it made a very loud scraping sound like metal on metal. i thought it was the brakes but the noise seemed too loud for that and just disappeared after a few moments. this sound also came with no warning. the brakes were replaced at 40k miles and the truck now has 80k. the clutch was also replaced about 2 years ago because it made a loud scraping sound when releasing it from a dead stop. i'm really concerned because this noise was so loud everyone around stopped to look. but the sound hasn't happened again after driving about 20 miles. don't know what it could be? the clutch and brakes both seem to be fine now?

crimsonplanet is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-01-08, 05:13 AM
Back in the Saddle
 
BlutoBodine's Avatar
 
Join Date: May 2008
Posts: 17
Re: loud scraping noise 03 ranger

Just a wild guess here, but I'd check the belt/tensioner/idler and AC clutch/hub.

2008 Vista Blue Ranger XLT

AMSOIL
BlutoBodine is offline  
post #3 of 3 (permalink) Old 08-01-08, 01:51 PM Thread Starter
Registered User
 
Join Date: Aug 2008
Posts: 2
Re: loud scraping noise 03 ranger

thanks for the advice!
crimsonplanet is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome