a miss in my 94` - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-25-09, 01:51 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Location: kentucky
Posts: 3
a miss in my 94`

i have a 1994 modle ford ranger and it has a miss in it when engine is under a load such as when i hit a hill. i have to drive it most of the time in drive, because in over drive it misses like crazy. but as long as your going smooth it dont miss a beat. I have put new plugs in it, new plug wires and a fuel filter. what is the cause of this? What can i do to fix it?

couch22a is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-26-09, 09:06 AM
Registered User
 
Join Date: Sep 2009
Posts: 2
Re: a miss in my 94`

does it have coil packs
thekoontz is offline  
post #3 of 3 (permalink) Old 09-26-09, 04:07 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Location: kentucky
Posts: 3
Re: a miss in my 94`

yes it does.
couch22a is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome