Need help, Electricial problem really bad. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-07-2007, 21:22   #1 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 3
frown Need help, Electricial problem really bad.

Can someone help me with this! I have a 1996 ranger XLT SuperCab 4X4 in need of electricial assistance.

During the day, when the lights are off, when I press on the brake peddle, my dash board lights come on, the time on the radio dims to the point that it can not be seen, and all the other lights on the out side of the truck come on except the head lights.

Now, when I am not driving the truck, and I press the brake peddle, same thing happens and the chime that tells you that you left you light on starts chiming. When I drive the truck at night and the lights are on, none of this happens.

Also, when driving the truck and I put on my left turn signal, the radio starts to flash. There is another problem, but I do not think it is releated, two lights on the gauage cluster are not functioning, and neither is the HVAC control lights.
ccusum is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-09-2007, 15:35   #2 (permalink)
Registered User
 
Join Date: Nov 2005
Posts: 42
Re: Need help, Electricial problem really bad.

Sounds like a grounding or I should say lack of grounding problem, I would check for broken or coroded wire at frame ground points, would also check tail lamp sockets for broken wires or corrosion. DC voltage systems are wierd.
mtneer57 is offline   Reply With Quote
Old 09-10-2007, 05:28   #3 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 3
Re: Need help, Electricial problem really bad.

Thanks, Do you know where the ground points are on a 1996 Ranger?
ccusum is offline   Reply With Quote
Old 09-18-2007, 18:46   #4 (permalink)
Registered User
 
Join Date: Nov 2005
Posts: 42
Re: Need help, Electricial problem really bad.

Sorry, haven't been on in a couple days. Their should be a black wire from tail light assemblies to frame near the rear of the vehicle also under the hood their will be grounds from motor to body and may be one from negative battery terminal to the body, not sure of exact locations.
mtneer57 is offline   Reply With Quote
Old 09-19-2007, 06:25   #5 (permalink)
Registered User
 
Join Date: Aug 2007
Posts: 3
Re: Need help, Electricial problem really bad.

Thanks for the reply, I actually figured it out. It was the wiring harness for the trailer hitch. Removed it and my problem we away.

Thanks for the help.

Chris.
ccusum is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.