need radiator help!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-18-06, 07:10 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 13
confused need radiator help!!!

I replaced my radiator today, pretty easy job, went very good, but i have one problem. The top line for the transmission is leaking. It just drips a little, i took the old o ring off the old radiator and it is better, but still seeping. I thought maybe the line just wasnt lining up good, as i could put pressure on the line and it would stop, i tried flexing the line a little and it did help, but still leaks. This is a aftermarket radiator, it may be that it is just a little difference that the line doesnt seat well, im afaraid to try to bend it much, has anyone had this issue? The bottom line is ok, doesnt leak, the line is not cross threaded, its leaking past the o ring, if i gently put pressure on the line the leak stops, that seems to me that the line is not seated good against the o ring, i am open to any help, thanks

packy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-19-06, 04:33 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 13
Re: need radiator help!!!

found the problem, the fitting that the tranmission line is different it wouldnt seal, put the old radiator back in and no leak. Anyone know where to get a good aftermarket radiator? I went to autozone and they had one just like the one i tried, the fittings on that one were wrong too, i would hate to have to go to ford for one, but might have too.
packy is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome