NO Codes & Runs like crap - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-31-10, 09:23 AM Thread Starter
Registered User
 
Join Date: Dec 2010
Posts: 1
NO Codes & Runs like crap

I have a 1994 ford ranger (splash) w/ a 3.0 L, it runs like crap and stalls when the clutch is depressed.
It has a new distributer pick up and complete tune up, Most of the time it runs like it's missing and every once in
a while it runs like it has a vaccum leak. Ran two diffrent scans on it which showed all sensors are good,
and it that it can not regulate the idle. At first we thought that it was the EGR valve since it came up
as zero voltage, But here is the kicker there has never been an EGR valve on it the bosses have never been
drilled,it has a new battery and when it's cold out it gose dead had the battery checked along w/ the starter and
alternator all are good, on top of that the truck was built 12/94, Hope you can help everyone I have talked with has no
idea and are suprised about there being no EGR valve.

I turned up the idle screw to keep it running and it smells like it is running a little on the rich side.

terrbo1968 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-31-10, 11:11 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,326
Re: NO Codes & Runs like crap

That "idle screw" is really a throttle stop and should never be changed. Try cleaning the MAF with MAF cleaner and see if it helps. Has it had new plugs and wires lately?

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome