No crank on '93 Ranger - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-10-07, 09:41 AM Thread Starter
cassijer
 
Join Date: Jan 2007
Posts: 7
confused No crank on '93 Ranger

I just replaced the starter on my '93 Ranger.

After installing the new one, it started up just fine. I took it for a drive and parked it in my garage over night. When I went to start it the next morning there was absolutely no juice, not even the dome light turned on when I opened the door. Somehow the battery was drained over night. I want to charge it, but I'm sure it will drain again so I'd like to fix the problem first.

Any ideas?

cassijer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-11-07, 09:41 AM
issuer of free advice
 
mre_power's Avatar
 
Join Date: Nov 2006
Location: la la land
Posts: 231
Re: No crank on '93 Ranger

i cant tell with out looking at it, and you charging the battery back up. it could be any number of shorts. and lights being left on.
mre_power is offline  
post #3 of 3 (permalink) Old 01-11-07, 10:24 AM Thread Starter
cassijer
 
Join Date: Jan 2007
Posts: 7
Lightbulb Re: No crank on '93 Ranger

You hit it on the head, after charging the battery and hooking up the cables the dome light turned on. Talk about bad timing to leave a light on.

Problem solved.
cassijer is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome