No oil pressure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-12-2009, 11:50   #1 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 4
No oil pressure

00 Ranger XLT
3.0 L

Bought this truck a week ago. This morning, I started her up, put it in drive, drove a few feet and noticed zero oil pressure. Listened for a few seconds - no valve clanking, no strange noises, then shut it down. Waited a few minutes, started again, no pressure, gunned it a little, no pressure, shut it down and left it in the drive way today.

When I start checking this out tonight, a mechanical oil pressure check will probably be be high on the checklist. Is there a specialized gauge for this? Does it screw into the sender output?

Any additional advice would be appreciated.
carphead is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-12-2009, 12:11   #2 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,706
Re: No oil pressure

Yep, you can screw it in the same spot. Sometimes there is a plug in the block that you can remove. Hopefully you just need a new senting unit.
thefonz is offline   Reply With Quote
Old 06-12-2009, 17:53   #3 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 4
Re: No oil pressure

So where is that sending unit.. I know it's on the block, I'm just not seeing it.
carphead is offline   Reply With Quote
Old 06-14-2009, 04:41   #4 (permalink)
Registered User
 
Join Date: Feb 2009
Posts: 4
Re: No oil pressure

Replaced the oil pressure sendor (7.79 Duralast; Motordraft was 23.50, but out of stock), issue solved.

Just to document: On the 3.0 the sensor can be reached by unbolting the front of the passenger side wheel well liner and reaching thru. On the 2000, It's a 13/16 deep; I've heard 1 1/16 on later models. Once you're in position to reach the sensor, the fix is pretty easy.
carphead is offline   Reply With Quote
Old 06-14-2009, 10:02   #5 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,706
Re: No oil pressure

Glad you solved your problem!
thefonz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.