No oil pressure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-12-09, 12:50 PM Thread Starter
Registered User
 
Join Date: Feb 2009
Posts: 4
No oil pressure

00 Ranger XLT
3.0 L

Bought this truck a week ago. This morning, I started her up, put it in drive, drove a few feet and noticed zero oil pressure. Listened for a few seconds - no valve clanking, no strange noises, then shut it down. Waited a few minutes, started again, no pressure, gunned it a little, no pressure, shut it down and left it in the drive way today.

When I start checking this out tonight, a mechanical oil pressure check will probably be be high on the checklist. Is there a specialized gauge for this? Does it screw into the sender output?

Any additional advice would be appreciated.

carphead is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-12-09, 01:11 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: No oil pressure

Yep, you can screw it in the same spot. Sometimes there is a plug in the block that you can remove. Hopefully you just need a new senting unit.
thefonz is offline  
post #3 of 5 (permalink) Old 06-12-09, 06:53 PM Thread Starter
Registered User
 
Join Date: Feb 2009
Posts: 4
Re: No oil pressure

So where is that sending unit.. I know it's on the block, I'm just not seeing it.
carphead is offline  
post #4 of 5 (permalink) Old 06-14-09, 05:41 AM Thread Starter
Registered User
 
Join Date: Feb 2009
Posts: 4
Re: No oil pressure

Replaced the oil pressure sendor (7.79 Duralast; Motordraft was 23.50, but out of stock), issue solved.

Just to document: On the 3.0 the sensor can be reached by unbolting the front of the passenger side wheel well liner and reaching thru. On the 2000, It's a 13/16 deep; I've heard 1 1/16 on later models. Once you're in position to reach the sensor, the fix is pretty easy.
carphead is offline  
post #5 of 5 (permalink) Old 06-14-09, 11:02 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: No oil pressure

Glad you solved your problem!
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome