No turn signals - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-11-2010, 22:10   #1 (permalink)
Registered User
 
Join Date: Mar 2006
Location: Seattle
Age: 49
Posts: 42
No turn signals

Hi y'all,

Been a while since I last posted as my 92 Ranger supercab has been super reliable, even with 227K+ miles on the odo despite having to replace both the master and slave clutch cylinders in the nearly 4.5 years of ownership and it still runs great, however with one teensy little problem.

I have no turn signals, literally, I have my 4 way hazards, the reverse lights, tail and brake lights and even checked the fuse (had to Google the diagram to ensure I got the right fuse and it's good) and all lights work as they should be but when I turn the left signal on, nothing, not even a glow from the dash indicators, same with the right but they work once I hit the 4 way flasher though.

And it seems my driving lights (stock as they came standard on the STX grade trucks as this one is) aren't working as the switch's LED no longer glows but need to confirm that however when the headlights are on, which is when they only work anyway and the cruise control still works although the on/off indicator no longer works but it DOES work still.

I'm just hoping it's not the multi-function stalk as the wipers and all intermitten speeds still work, the washer fluid button still functions and all that but no signals.

This truck has the towing package w/ hitch and round electrical connector, it's a tad corroded despite the door being closed to help protect it as I don't use it much since I have no need to tow anything, would that have anything to do with it?

I think the problem may have gone on for at least a month or two but not much longer. It was sometime this spring when I began to notice the left indicator at least wasn't working and thought I saw the right side work but may be very mistaken until I noticed the entire problem yesterday on my way home from work.

Any ideas?

Thanks.
92rangerstx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-12-2010, 07:54   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,703
Re: No turn signals

I would bet that it's the multi- function switch. They're easy to change. Just pull the steering column housin panels off and there are 2 torx screws to remove. Those and the plugs and it's done. You can probably get them to work for a short time by spraying electric contact cleaner in around the hazard button and turn them on and off a few times.
__________________
Bert
Bert is offline   Reply With Quote
Old 06-12-2010, 09:29   #3 (permalink)
Registered User
 
Join Date: Mar 2006
Location: Seattle
Age: 49
Posts: 42
Re: No turn signals

Thanks,

Was afraid it might be the multi function switch and am glad it's not difficult to replace.

Are they expensive BTW or should I try to find one in a junk yard?

Meanwhile I'll try cleaning it and see if they return to functionality for the time being.
92rangerstx is offline   Reply With Quote
Old 06-12-2010, 13:01   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,703
Re: No turn signals

They are around $100. Rock auto, one of our sponsors has them and being a member here, they give a discount. Check our sponsor forums, Also you can check for a used one here. Car-Part.com--Used Auto Parts Market
__________________
Bert
Bert is offline   Reply With Quote
Old 06-16-2010, 18:43   #5 (permalink)
Registered User
 
Join Date: Mar 2006
Location: Seattle
Age: 49
Posts: 42
Re: No turn signals

Thanks for the reply back, last weekend I went out and got at the switch, squirted some cleaner stuff in it and nope, nothing, although I still have wipers and washer and 4 way hazards but no turn signals.

This weekend I'm a gonna hit my local junk yard and buy one from a wrecked truck and make that do as I'm hoping early next year to replace the truck.
92rangerstx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.