now the amp is haunted - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-06-04, 09:03 AM Thread Starter
Cheetah :D
Join Date: Dec 2003
Location: California
Age: 29
Posts: 19
now the amp is haunted

hello guys, i am not having much luck with electronic stuff in my truck.
last friday i was driving and my amplifier shuts off, i tryed checking the fuses and they were allright. The amp smelled really bad! anyways i let it cool down and then it did not turn off. is it fried?

i got an MA Audio mi series
Cheetah is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-08-04, 12:43 AM
Registered User
Join Date: Apr 2004
Posts: 8
Re: now the amp is haunted

I'd say you probably got a defective amp. I've seen this before on a Kenwood amp and what can sometimes happen is a wire will not get properly soldered on at the factory. The vibration of daily driving works it loose and ZAP! game over. If it's still on warranty, send it back to the factory, they may be able to fix it. Good Luck!
Lone Ranger5.8 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone else have a Sony P5 series amp? dhartley Audio And Security 1 03-26-04 07:50 PM
What is wrong with my amp? HELP!!! DansEdgli Audio And Security 6 03-03-04 04:56 PM
JL Audio Mono block amp getting too hot EFXR62 Audio And Security 49 11-03-03 07:47 AM
amp in au rebel01 Audio And Security 1 09-06-03 11:28 AM
amp problems EFXR62 Audio And Security 2 04-25-03 08:06 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome