P0171 Code on a 2001 2.3. PCV valve? O2s? Help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-09-07, 08:00 PM Thread Starter
Registered User
 
Join Date: May 2007
Posts: 1
Question P0171 Code on a 2001 2.3. PCV valve? O2s? Help!

I got a P0171 (Engine too lean (bank 1)) on a 2.3L 2001 Ranger. Replaced the airfilter, cleaned the MAF sensor with tuner cleaner, light comes back. been driving for a couple weeks, but i'd like to get it cleared up. truck is stock in every way.

anyone had the problem? I'm thinking PCV valve perhaps, or maybe O2 sensors? doubt its EGR...

Any help/experience would be appreciated.

thanks in advance!

morttt is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-01-07, 07:50 PM
Registered User
 
Join Date: Jul 2007
Posts: 10
Re: P0171 Code on a 2001 2.3. PCV valve? O2s? Help!

Check for vacuum leaks. Likely suspect is a cracked vacuum hose connecting fuel pressure regulator to the intake manifold.
Attached Images
File Type: jpg IMG_2201.JPG (19.6 KB, 21 views)
File Type: jpg IMG_2204.JPG (10.2 KB, 27 views)
File Type: jpg IMG_2205.JPG (12.3 KB, 22 views)
tomcas is offline  
post #3 of 5 (permalink) Old 09-25-07, 05:24 PM
Registered User
 
Join Date: Nov 2005
Posts: 42
Re: P0171 Code on a 2001 2.3. PCV valve? O2s? Help!

Could be upstream O2 sensor on that bank.
mtneer57 is offline  
post #4 of 5 (permalink) Old 05-17-14, 11:52 AM
Registered User
 
Join Date: May 2014
Posts: 1
Re: P0171 Code on a 2001 2.3. PCV valve? O2s? Help!

I have a similar situation. P0171 code and it idles normally. As long as I keep RPM above 2500 or so it seems to run normally. It stumbles if below with any load. The vac. hose looks good, though. How do I check upstream O2 sensor? I can't find an upstream O2 Sensor, just the one on top of the Cat. I see that AutoZone lists one, though. Any help would be greatly appreciated. Alan

Last edited by SKSAlan; 05-17-14 at 01:06 PM. Reason: More questions
SKSAlan is offline  
post #5 of 5 (permalink) Old 05-17-14, 03:37 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,661
Re: P0171 Code on a 2001 2.3. PCV valve? O2s? Help!

Any air leak could cause this in the vacuum system, also insufficient fuel. Not sure on the 2001, but the older explorer (pretty much the same under the skin) had the O2 sensor on either side of the Cat.

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome