P0402 - Keep getting this code... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 05-17-10, 02:40 PM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
P0402 - Keep getting this code...

I have a 2001 Ranger 4x4 ext. cab, w/ 4.0l v-6, AT and 146,000 miles, and I keep getting the code P0402. I've replaced the EGR valve and DPFE sensor. All of the hoses, including the ones for the DPFE sensor appear to be fine.

Strange thing is I can clear the code and not receive it again until I take it on a long drive. Long drive = 2+ hours of driving around shopping with the wife. I can drive around for weeks at a time, just going to and from work, and not have the CEL come on.

Is there anything else I can try to get rid of the CEL?
ufgators68 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 05-17-10, 04:47 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: P0402 - Keep getting this code...

Here's a little informaton on the code. OBD-II Trouble Code: P0402 Exhaust Gas Recirculation (EGR) Flow Excessive Detected

Bert
Bert is offline  
post #3 of 12 (permalink) Old 05-18-10, 05:15 AM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
Re: P0402 - Keep getting this code...

Thanks for the reply but I've been there and done that... that's where I got the idea to change the dpfe sensor, after I changed the egr valve.

Now mysteriously, the CEL has gone off. Drove it to lunch yesterday and when I left, to go home, the light didn't come back on.
ufgators68 is offline  
post #4 of 12 (permalink) Old 05-18-10, 01:24 PM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
Re: P0402 - Keep getting this code...

I may have possibly found the problem... there was no gasket included with the replacement EGR valve. It's showing one on the Motorcraft site but there wasn't one in the box. Apparently it's an additional piece.

Would a leak, where the EGR valve mounts to the engine, cause the P0402 code to pop up?
ufgators68 is offline  
post #5 of 12 (permalink) Old 05-18-10, 06:38 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: P0402 - Keep getting this code...

It's possible. Fix the leak and see what happens.

Bert
Bert is offline  
post #6 of 12 (permalink) Old 05-19-10, 05:19 AM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
Re: P0402 - Keep getting this code...

I guess I'll find out this weekend when we go shopping to replace all of the food that our fridge decided to let ruin, when it died.
ufgators68 is offline  
post #7 of 12 (permalink) Old 05-19-10, 09:06 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: P0402 - Keep getting this code...

Sorry to hear about the refridgerator. It seems like always something. Good luck and hope it turns out okay.

Bert
Bert is offline  
post #8 of 12 (permalink) Old 05-24-10, 06:19 AM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
Re: P0402 - Keep getting this code...

Well... that didn't work. It's funny, I can drive to work all week long but the moment I take a longer drive, the CEL comes on. Usually while I'm running the A/C.

I'm about ready to just replace all of the hoses.
ufgators68 is offline  
post #9 of 12 (permalink) Old 05-25-10, 06:11 AM Thread Starter
Registered User
 
Join Date: May 2010
Location: Mississippi
Age: 40
Posts: 11
Re: P0402 - Keep getting this code...

And the CEL has turned off again... on it's own. Was on yesterday, on my way home from work, but when I fired her up this morning... the light was off.
ufgators68 is offline  
post #10 of 12 (permalink) Old 05-25-10, 08:31 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,281
Re: P0402 - Keep getting this code...

Hopefully, it stays off.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome