Panel, ac control, and tail lights don't work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-12-07, 05:16 PM Thread Starter
Registered User
 
Join Date: Nov 2007
Posts: 1
Panel, ac control, and tail lights don't work

I recently installed a new after market stereo and now my panel, ac control and tail lights don't work. I don't understand because I have put in three stereos in this truck exactly the same way. Anyway, I have a 97 ranger regular cab. Any help would be appreciated. By the way the fuses are fine.

allenma is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-12-07, 07:01 PM
Registered User
 
ranger_guy_82's Avatar
 
Join Date: Mar 2007
Location: Omaha, NE
Age: 34
Posts: 123
Re: Panel, ac control, and tail lights don't work

The only thing I can think of is maybe you pulled a wire loose somewhere in there.
ranger_guy_82 is offline  
post #3 of 5 (permalink) Old 11-13-07, 04:22 PM
Plum Krazy XLT
 
Shadow's Avatar
 
Join Date: Jun 2003
Location: Ohio, USA
Age: 58
Posts: 47
Re: Panel, ac control, and tail lights don't work

Be sure you check all the bulbs on the back. This should be a warning. If tail and brake lights are not working, instrument lights go off to warn you. Don't ask who's logic that is.

The Shadow
Shadow is offline  
post #4 of 5 (permalink) Old 11-13-07, 07:27 PM
Registered User
 
ranger_guy_82's Avatar
 
Join Date: Mar 2007
Location: Omaha, NE
Age: 34
Posts: 123
Re: Panel, ac control, and tail lights don't work

I guess u learn somethin new everyday!....I didnt know that if your tail and brake lights go out, the instrument lights go out as well....I gotta quit drinkin...lol...Good lookin out!....
ranger_guy_82 is offline  
post #5 of 5 (permalink) Old 11-17-07, 11:22 PM
Registered User
 
Join Date: Nov 2007
Posts: 4
Re: Panel, ac control, and tail lights don't work

There have been many a time that I have said, "the fuses are fine!", only to find out hours and hours later, that they are not. This may not be your problem, but be sure to check ALL fuses in foot are and under hood. Rig up a simple 12V light checker.
mgilbe1 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome