ranger runs rough after warms up - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-12-2009, 12:48   #1 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 13
ranger runs rough after warms up

my 89 ranger runs good when cold but rough after gets to operating temp changed plugs cap rotor condensor at a loss as to where to look next
kimmell2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-12-2009, 15:50   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: ranger runs rough after warms up

Does it feel like a steady miss or erratic roughness. At idle, in gear, or higher rpms?
Bert is offline   Reply With Quote
Old 10-13-2009, 01:52   #3 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 13
Re: ranger runs rough after warms up

it runs rough mainly accelerating going through the gears and high speeds pretty much steady oh and engine light flashes
kimmell2002 is offline   Reply With Quote
Old 10-13-2009, 08:23   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: ranger runs rough after warms up

Use this procedure to see what codes you can find. The code information is at the bottom of the page.

Troublcodes.net Trouble Codes OBD & OBD2 Trouble Codes and Technical info & Tool Store. By BAT Auto Technical
Bert is offline   Reply With Quote
Old 10-14-2009, 13:35   #5 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 13
Re: ranger runs rough after warms up

i did the code pull according to link sent the engine light flashed so much i got dizzy how do i figure codes by flashes
kimmell2002 is offline   Reply With Quote
Old 10-14-2009, 13:48   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: ranger runs rough after warms up

They're all 2 digit codes, You'll probably have too run it more than once if there are lot's of codes. If you reread the procedure, it tells of a 2 sec. pause between digits and Continuous Memory DTCs are separated from Key On Engine Off DTCs by a six second delay, a single half second flash, then another six second delay. Here's what they indicate. OBD-I Diagnostic Trouble Codes
Bert is offline   Reply With Quote
Old 10-14-2009, 18:14   #7 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: ranger runs rough after warms up

What engine is it?
Bert is offline   Reply With Quote
Old 10-15-2009, 05:14   #8 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 13
Re: ranger runs rough after warms up

2.9. could it be fuel pressure ? seems like injectors rattling more than they should
kimmell2002 is offline   Reply With Quote
Old 10-15-2009, 19:57   #9 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: ranger runs rough after warms up

I never heard them rattle other than their normal ticking, even with low fuel pressure. Can you check the pressure? What codes did you get. It may take afew times to get the feel of how they work.
Bert is offline   Reply With Quote
Old 10-17-2009, 19:09   #10 (permalink)
Registered User
 
Join Date: Oct 2009
Posts: 13
Re: ranger runs rough after warms up

bought code scanner today pulled codes stored in comp nothing there key on engine off no codes key on engine on o2 sensor pulled codes again nothing .reader said could not detect full throttle test even aftera newthrottle position sensor
kimmell2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.