runs poorly when hot - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-06-09, 11:45 AM Thread Starter
Registered User
Join Date: Sep 2009
Posts: 1
runs poorly when hot

1999 ford ranger 3.0

truck runs fine when it is cold but once it gets up to operating temperature it loses about 1/3 of its power. Under a load like going up a hill I notice alot of pinging. I need to shift down even on the smallest of grades. If I step on it like I want to pass someone it pings like crazy and ultimately displayes very little power all the while pinging like crazy. Any suggestions?
tamochin is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-06-09, 09:49 PM
2002 F150 XLT
Bert's Avatar
Join Date: Nov 2008
Location: Oregon
Posts: 10,238
Re: runs poorly when hot

Have you changed the fuel filter? They can cause a lean ping if they're restricted. How old are the spark plugs? Another thing is to get a MAF cleaner and clean the MAF.
Bert is offline  
post #3 of 3 (permalink) Old 09-15-09, 05:04 PM
360ci's Avatar
Join Date: Nov 2007
Location: Waterloo
Posts: 2,477
Re: runs poorly when hot

If the engine is knocking under load - I would advise against giving it any more fuel or you'll have more problems on your hands. Still, even if the plugs aren't all that old (say two years with lower miles), pull one or two out and make sure they look OK (not burnt/electrode missing, etc). If the fuel system checks out OK, get a compression test done.

'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome