speed sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Ranger Forum Forum for discussion of the Ford Ranger.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-29-06, 09:18 AM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 1
speed sensor

I have a 99 ranger v6 3L with a Speed Sensor diagnostics trouble code. Speedometer works, but the abs light stays on. Just wanted to confirm how many speed sensors those this truck have and which one is most likely responsible for my check engine light coming on.
bstd2gen7 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-09-06, 08:04 PM
Registered User
 
Join Date: Dec 2005
Posts: 49
Re: speed sensor

Quote:
Originally Posted by bstd2gen7
Speedometer works, but the abs light stays on.
Well Im not shure about your check engine light, but if your ABS light stays on than either your ABS motor is shot, one of the ABS sensors in the wheel assem is bad or corroded. If you get an ABS chatter at low speeds its definatly the motor. O and the sensors arent cheap, they where $115 A PIECE! and they where a dealer part for the year truck I put them in, was a 95.
MadModderModa is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome