Wiper Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Ranger Forum Forum for discussion of the Ford Ranger.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-28-2005, 15:25   #1 (permalink)
Registered User
 
Join Date: Apr 2005
Posts: 1
Wiper Problem

I was wondering if anyone else has had this same problem. I own a '95 extended cab pu and my wipers have a mind of their own! They come on whenever they want and don't always shut off when I turn them off. Any suggestions? A mechanic I brought it to last spring swore it was the wiper motor so he replaced it. Didn't work. I have also been told it is some kind of module that costs about $300 to replace, but I don't want to spend it if that's not what's wrong. Any help would be greatly appreciated.
E-mail me @ shutterbug@metrocast.net
Thanks,
Ruth
photonut is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-18-2006, 18:10   #2 (permalink)
Registered User
 
Join Date: Mar 2006
Posts: 2
Re: Wiper Problem

i have a similar problem my wipers sometimes work on all the mediums. they always wokr on high tho its annoying cuz whn i turn them off i gotta time it so itts lay flat. if u find an answer let me know
mx skater is offline   Reply With Quote
Old 04-21-2006, 13:32   #3 (permalink)
Registered User
 
Join Date: Apr 2006
Posts: 3
Re: Wiper Problem

I just bought a 97 SC SB and everything worked but the intermittent wipers. Spent some hours on forums researching the problem and finally found a post on how to fix wipers if they quit on the road. There are two relays under the hood connected with the wipers. The manual calls one a high low wiper relay and the other just wiper relay. I switched the relays and the symptoms changed but it was still screwy. Switched the horn relay (it's identical and alonside others) and after I found the right slot, the wipers work like a charm. Surprisingly, the horn still works too.
Now the washer quit, but it's in the switch. There are tiny prongs which have to be bent exactly right. Got tired of bending the little thing for today but I will eventually have a fully functional wiper/washer system

Hope this helps somebody else, this system is poorly designed with the absolute minimum of material.
gfcrane is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Ranger Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:53.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.