'90 Topaz Spittin' and Sputterin' REAL bad! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Tempo Forum | Mercury Topaz Forum Forum for discussion of the Ford Tempo and Mercury Topaz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-15-2009, 13:31   #1 (permalink)
Registered User
 
Join Date: Mar 2009
Posts: 2
'90 Topaz Spittin' and Sputterin' REAL bad!

Well, the other day i got in the car and started going down the road i noticed when i stepped on the gas, it started sputterin' real bad and was actin like it didnt wanna go anywhere. Best way to describe it to me, is it sounds like its sick and has a cough. It does it in all gears, it'll just sit there in park even and sputter nonstop. Sometimes its worse than others, going uphill is a real challenge its so bad. I replaced the IAC last month because i was having a high idle problem, that fixed the high idle problem, but now i have this. I also replaced spark plugs, plug wires, cap, and rotor.

My dad seems to think it may be electrical and he describes it as, "seems like theres a short somewhere and isnt making the proper connection". Now i know if its electrical it could be a whole bunch of things. He also said he didnt think it was the fuel pump because the fuel pump would just stop working and wouldnt make the car run, correct?

Im at a loss, this thing is my daily driver and i need this to last me for quite sometime. Im afraid to drive it to work because i dont know if its going to quit on me or something. It hasnt yet, but it acts like it wants to.
PLEASE HELP!
MichaelShreds is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-15-2009, 22:48   #2 (permalink)
Registered User
 
RickyRetardo's Avatar
 
Join Date: May 2009
Location: 42°54′39″N 74°34′29″
Posts: 23
Re: '90 Topaz Spittin' and Sputterin' REAL bad!

Do you smell gas while the car is running? What else do you notice going on? What codes is the ECM throwing?

My first thought was a lean condition but a rich condition can have the same effect. So could poor voltage to the pump, a bad pump, clogged filters...
RickyRetardo is offline   Reply With Quote
Old 06-19-2009, 12:41   #3 (permalink)
Pantherholic
 
87_Crown_Vic's Avatar
 
Join Date: Apr 2009
Location: Omaha, NE
Age: 34
Posts: 370
Garage
Re: '90 Topaz Spittin' and Sputterin' REAL bad!

had this happen to me before. a spark plug came loose and made it act up. i would check plug wire connections, plugs for tightness, make sure the plug wires are connected to correct plugs, and also buy a fuel filter for the car.
__________________

my 1986 Grand Marquis LS... Rose...
87_Crown_Vic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:06.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.