92 topaz radiator fan controler? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Tempo Forum | Mercury Topaz Forum Forum for discussion of the Ford Tempo and Mercury Topaz.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-22-08, 12:43 PM Thread Starter
Registered User
Bumbledor's Avatar
Join Date: Mar 2008
Posts: 32
Question 92 topaz radiator fan controler?

Ok guys, now another problem has popped its ugly head up.

The radiator fan is not operating properly.

According to my manual, there is a tempature switch on the termostant housing. using a DVM, I took resistance measurments with both a hot and cold engine.

The switch checked out ok. but if I pull the wire off the switch when the car is warm, The fankicks on, wich it should not do. its only supposed to kick on when the switch reads zero or low resitance. With the wire off, three is maximum resitance between the 2 connectors. I.e like an open switch.

that tells me the problem is in the electronics.

92 mercury topaz, 3.2 4 cylendar, with AC.. WHERE do I find the electronics for the fan unit? My hayse manual says its behind the glove box, but it is no there.
Is it that big square black box that looks like a brain, on the driver side front strut mount?

Any help apprecated.
Bumbledor is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome