Changed Balancer, still have clank - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Tempo Forum | Mercury Topaz Forum Forum for discussion of the Ford Tempo and Mercury Topaz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-10-2005, 07:50   #1 (permalink)
Registered User
 
Join Date: Dec 2005
Posts: 1
Changed Balancer, still have clank

I changed my Harmonic Balancer, but am still having this clanging sound. I only notice it when I hit the gas pedal; but it stops once i am revved up. When I stop at a light, then hit the gas again, you hear it.

Could it be a belt? I didn't change my balancer 'cause of the clang. But, thought that the clang might be a side-effect of it.

Thoughts please.
findmeinthaA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-10-2005, 23:47   #2 (permalink)
Registered User
 
dagr8tim's Avatar
 
Join Date: Apr 2004
Location: Columbus, Ohio
Age: 38
Posts: 162
Re: Changed Balancer, still have clank

Check the motor/tranny mounts.
__________________
My Web Gallery
Crazy 'Bout A Mercury
1991 Topaz GS (2.3/auto) (gone with the ex Wife; I'll miss that car)
1999 Grand Marquis GS (4.6/auto)
dagr8tim is offline   Reply With Quote
Old 01-19-2006, 22:24   #3 (permalink)
93 2.3 MTX BOLTED OUT!
 
Cronicus's Avatar
 
Join Date: Sep 2005
Location: in my car pretty much
Age: 28
Posts: 626
Re: Changed Balancer, still have clank

could it be knocking?
__________________
Cronicus is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:46.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.