Horn problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Tempo Forum | Mercury Topaz Forum Forum for discussion of the Ford Tempo and Mercury Topaz.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-04-05, 06:43 AM Thread Starter
Registered User
 
Join Date: Mar 2005
Posts: 1
Horn problems

I have a '94 ford topaz. Horn doesn't work. Changed the fuse, still no avail. Solution?

davidperson is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-25-05, 06:50 AM
Registered User
 
Join Date: Jun 2005
Posts: 36
cool Re: Horn problems

Quote:
Originally Posted by davidperson
I have a '94 ford topaz. Horn doesn't work. Changed the fuse, still no avail. Solution?
My horn did never worked. After hitting a deer because I could not honk to scare it I looked into the problem. When taking the cover off the steering wheel, there is a plastic plunger inside a wire spring that makes contact with the metal on the horn when pressed. Mine was broken. This fixed and I have since scared many a deer away when I see them coming near the road. Good luck.
jeririah is offline  
post #3 of 6 (permalink) Old 07-08-05, 06:51 PM
grm
Registered User
 
Join Date: Jul 2005
Posts: 4
Re: Horn problems

My horn doesn’t work either, how do you take the cover off the steering wheel? Does it just pull off? Thanks grm
grm is offline  
post #4 of 6 (permalink) Old 07-08-05, 08:52 PM
63-1/2 Galaxie
 
Join Date: Sep 2004
Location: Vancouver Island
Posts: 323
Re: Horn problems

Check your horn relay and connections.
Butchart is offline  
post #5 of 6 (permalink) Old 07-11-05, 03:06 PM
BmK
Registered User
 
Join Date: Jul 2005
Posts: 6
Re: Horn problems

Hmmmm.... I have had a horn problem for some time. It started one day after smelling hot/burning wires, followed by a small wisp of smoke exiting the steering column. I later read on a consumer site that this problem was not unusual with this car. I have lived without a horn ever since (years).

Maybe I'll have a closer look....
BmK is offline  
post #6 of 6 (permalink) Old 10-01-05, 09:39 AM
93 2.3 MTX BOLTED OUT!
 
Cronicus's Avatar
 
Join Date: Sep 2005
Location: in my car pretty much
Age: 30
Posts: 626
Re: Horn problems

yup mines been gone science 100k and smoke came out 2 but out the back of my dash , so i removed the entire catalisyst and exhaust system and slaped a 3 foot glass pack on the ex manafold so now when sum 1 honks just drop N and rev high 1st n burn it,

btw u guys have no clue soup up ur tempo when i shift into second realy high it peels out for a second at like 60+ mph rofl and in third it barley peels just a lil
Cronicus is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 Ford Probe GT Intermittent Problems freddie Ford Probe Forum | Mazda MX6 Forum 1 11-14-04 02:13 PM
horn is having a fit???WTF??? mad_ea_spac General Tech 9 10-19-04 07:03 AM
Quality problems bedevil Jaguar's X-Type Stacy94PGT Ford Worldwide News 1 05-29-02 09:19 PM
Ford blames its suppliers for quality problems, demands improvement Stacy94PGT Ford Worldwide News 0 05-28-02 08:58 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome