New member - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Tempo Forum | Mercury Topaz Forum Forum for discussion of the Ford Tempo and Mercury Topaz.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-09-04, 03:59 AM Thread Starter
Registered User
dagr8tim's Avatar
Join Date: Apr 2004
Location: Columbus, Ohio
Age: 39
Posts: 162
New member

Hi, I just joined up today.

First off, I have a 91 Mercury Topaz GS. This is my 3rd Topaz, and my 5th TT.

Mainly, I can't seem to find my haynes manual and I'm looking for gruesome details for setting the timing.

I just changed the distrubitor and this thing is painfully out of time. It ran great before, but the distrubitor housing was cracked. Anyways, I've got a rich sitution. The car runs great, idles great. Just has no pickup and like I said, it's rich.
dagr8tim is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Tempo Forum | Mercury Topaz Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Donating member GTP 320 The Pub 1 07-23-03 04:39 AM
Coil spring swap with mustang K member 351LSC General PAG discussions 4 09-01-01 05:28 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome