1995 t-bid died HELP!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 08-29-11, 04:31 PM Thread Starter
Registered User
 
Join Date: Aug 2010
Posts: 29
1995 t-bid died HELP!!!

so my mom was driving going around a corner and it died then came back, but the next corner it dies and now wont start it will turn over but no start can smell fuel so i know its got fuel and air. so im thing ignition system what does it sould like to y'all?

shorty2tall is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 08-29-11, 04:38 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,137
Re: 1995 t-bid died HELP!!!

Sounds like lack of fuel , as you take corner the fuel splashes away from pickup pipe ?
R.S.LOGAN is offline  
post #3 of 23 (permalink) Old 08-29-11, 04:47 PM Thread Starter
Registered User
 
Join Date: Aug 2010
Posts: 29
Re: 1995 t-bid died HELP!!!

Quote:
Originally Posted by R.S.LOGAN View Post
Sounds like lack of fuel , as you take corner the fuel splashes away from pickup pipe ?
i can smell fuel when trying to start it tho

Quote:
Originally Posted by chipset View Post
Well a Y'ALL is a small boat. Don't call us that. If it's got gas and no spark that might be your problem.
i know theres no spark im not dumb im trying to figure out what might not be causing the spark thank u captain obvious.
im here for help not for someone to treat me like crap if i wanted that id be on pirate 4x4 not here!
shorty2tall is offline  
post #4 of 23 (permalink) Old 08-29-11, 04:57 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,137
Re: 1995 t-bid died HELP!!!

You dont mention no spark in original post , have you checked it or are you guessing thats the fault ?
R.S.LOGAN is offline  
post #5 of 23 (permalink) Old 08-29-11, 05:02 PM Thread Starter
Registered User
 
Join Date: Aug 2010
Posts: 29
Re: 1995 t-bid died HELP!!!

Quote:
Originally Posted by R.S.LOGAN View Post
You dont mention no spark in original post , have you checked it or are you guessing thats the fault ?
no but i did mention that i have fuel and air so guessing spark/ignition system. what is common to fail to cause this problem on these cars?
crank sensor?
is the tach supposed to move when cranking its not?
and also the battery light stays on while cranking.

its my moms car so i dont drive it much and dont pat attention to these little things.
shorty2tall is offline  
post #6 of 23 (permalink) Old 08-29-11, 05:06 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,137
Re: 1995 t-bid died HELP!!!

Check crankshaft position sensor.
R.S.LOGAN is offline  
post #7 of 23 (permalink) Old 08-29-11, 06:29 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,863
Re: 1995 t-bid died HELP!!!

Quote:
Originally Posted by chipset View Post
Well a YALL is a small boat. Don't call us that. If it's got gas and no spark that might be your problem.
Hey Chip? How is Y'ALL? Is Y'ALL doing well in Y'ALL'S part of the country? Just thought I would reply to Y'ALL'S post since it OFFENDS Y'ALL...

By the way, I deleted your post as other may find it offensive.
jwko is offline  
post #8 of 23 (permalink) Old 08-30-11, 01:11 AM Thread Starter
Registered User
 
Join Date: Aug 2010
Posts: 29
Re: 1995 t-bid died HELP!!!

Quote:
Originally Posted by R.S.LOGAN View Post
Check crankshaft position sensor.
ok so me and a friend got the battery replaced and alternator tested it was good now that the car cranks better its not sending spark would the crankshaft position cause that?
if so wheres it located?
BTW thanks for ur help!!!

Quote:
Originally Posted by jwko View Post
Hey Chip? How is Y'ALL? Is Y'ALL doing well in Y'ALL'S part of the country? Just thought I would reply to Y'ALL'S post since it OFFENDS Y'ALL...

By the way, I deleted your post as other may find it offensive.
thank u! JWKO
shorty2tall is offline  
post #9 of 23 (permalink) Old 08-30-11, 08:35 AM Thread Starter
Registered User
 
Join Date: Aug 2010
Posts: 29
Re: 1995 t-bid died HELP!!!

How do I check the crankshaft position sensor?
And would that cause no spark?
shorty2tall is offline  
post #10 of 23 (permalink) Old 08-30-11, 08:35 AM
Moderator
 
Join Date: Nov 2008
Posts: 1,139
Re: 1995 t-bid died HELP!!!

JWKO. That is hilarious. Made my day. The tbird problem could be a spark module ( most
likely ) to crank sensor to a wire sawed off in the steering column shutting down power to
the ign. system. There has to be tests done. We still don't know what engine. At least i
didn't see one mentioned.
chipset is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome