'66 T-Bird 390 secondary venturis not opening - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-21-07, 10:17 PM Thread Starter
Registered User
 
Join Date: May 2007
Location: British Columbia, Canada
Posts: 2
'66 T-Bird 390 secondary venturis not opening

Folks,

I'm new to Fords, and have a '66 T-Bird with a stock 390. It's sat for twenty years, and I got it running three days ago.

The secondary carb venturis are not opening; I think they're vacuum.

Ideas?

Thanks,


David
David.Randall is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-23-07, 11:26 PM Thread Starter
Registered User
 
Join Date: May 2007
Location: British Columbia, Canada
Posts: 2
Re: '66 T-Bird 390 secondary venturis not opening

The problem turned out to be that the secondary throttle shaft was seized. I worked it loose, and everything is working now.
David.Randall is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome