95' thunderbird 4.6 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-20-12, 04:15 PM Thread Starter
Registered User
 
Join Date: Aug 2012
Posts: 1
95' thunderbird 4.6

My t-bird dies out after about 5min of driving. Fuel system ok. MAF and CKP sensors OK. Spark OK. Issue started after letting vehicle sit for about 3weeks. What could be causing this?
CJDFord is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-20-12, 06:14 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,455
Re: 95' thunderbird 4.6

Couple of questions:
No diagnostics?
Does it die suddenly or lose power first?
Did you check for critters?

My wife and I took a month to visit family while I was in the Navy and family of chipmunks took residence in the air cleaner.

Little bastards.
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome