96 t'bird heater problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-30-05, 02:45 PM Thread Starter
Registered User
Join Date: Oct 2005
Posts: 1
96 t'bird heater problem

My 96 t'bird will not blow hot air when the heater is on. I have replaced the heater core, thermostat, and blending motor all within the past year. Any ideas?
grymz2 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-16-05, 09:06 PM
Registered User
Join Date: Nov 2005
Posts: 25
Re: 96 t'bird heater problem

Is it the heater that is not working or the heater fan that doesn't work. Warm it up and put your hand under the dash where the air flow normally comes from. If there's heat your problem is the heater fan or possibly the vent mechanism. Replacing a heater fan and motor seems daunting at first but is easy if you follow directions, in a Hanes Repair Manual for instance, and exercise patience.

Good luck.
mgcanada is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome