advice or leads for 1988 T-bird - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-30-04, 09:38 AM Thread Starter
Registered User
Join Date: May 2004
Posts: 1
Tongue advice or leads for 1988 T-bird

My mom has a 1988 Thunderbird and has kept it in AMAZING shape.
After a bad accident 2 years ago it's almost good as new. She is just missing a few pieces of chrome trim over each wheel (3 are missing) and a hard to find screw for the armrest. Any advice or leads?

This car has a canvas top - and the canvas is still in good shape but the stiching is starting to go. Any leads on a good upholsterer in the Long Island area?

thanks for any and all help and advice

Mary P
marypnyc is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-08-04, 03:29 PM
Registered User
Join Date: Jul 2004
Posts: 7
Re: advice or leads for 1988 T-bird

not sure which screw on the armrest your talking bout but if its one of the ones holding the armrest down they are pretty much hidden so any screw long enough should work or are you talking about those white lil clip things that attach the armrest to the metal and if so those always come off on mine too but im preety sure almost any hardware store carries those
sk8er629 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sparkplug leads barry_v General Tech 4 04-06-04 06:15 AM
EAGhiaII Auto advice please!! AU_Fairmont -S- Trans | Driveline 6 04-04-04 09:11 AM
Quick question about leads and their random effects... 6pAc|30nG|00n General Tech 1 12-13-03 08:44 PM
5.0 Missing after plugs and leads change NZ Windsor Tech 2 12-03-03 11:45 PM
What HT leads are you using?? svo347 General Tech 3 12-01-01 06:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome