"check engine ligth" ON - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Thunderbird Forum Forum for discussion of the Ford Thunderbird.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-29-2004, 22:15   #1 (permalink)
Registered User
 
Join Date: Sep 2004
Posts: 4
"check engine ligth" ON

I have 1997 ford thunderbirs 4.6eng,it's got the check engine ligth ON. I did a diagnostic and get no codes.Do you guys have any idea waht's the problem?
rookie70 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-03-2004, 21:51   #2 (permalink)
Registered User
 
Join Date: Sep 2004
Posts: 4
Re: "check engine ligth" ON

[QUOTE=rookie70]I have 1997 ford thunderbirs 4.6eng,it's
rookie70 is offline   Reply With Quote
Old 06-12-2005, 07:13   #3 (permalink)
Experienced Novis
 
Join Date: Jun 2005
Age: 52
Posts: 3
Re: "check engine ligth" ON

A mechanic friend of mine has the same car us and told me he had the same problem. His turned out to be a coil pack going bad, it had not failed so it did not show up on the diagnostic.
Vagrant is offline   Reply With Quote
Old 03-12-2006, 09:01   #4 (permalink)
JoeBirdLX
 
Join Date: Mar 2006
Location: St.Louis
Age: 47
Posts: 2
Re: "check engine ligth" ON

Go to Autozone and have them pull the coded for you. The ECU connector is located on the passenger side under the glove box. It is probably a misfire. Just unplug the battery for a few minutes the light will go out until you get another misfire.
jurban is offline   Reply With Quote
Old 04-01-2006, 07:14   #5 (permalink)
Unregistered
Guest
 
Posts: n/a
Re: "check engine ligth" ON

Quote:
Originally Posted by rookie70
I have 1997 ford thunderbirs 4.6eng,it's got the check engine ligth ON. I did a diagnostic and get no codes.Do you guys have any idea waht's the problem?
First off you do have a code kicking the light on. Reserch has found not all scanners are created equally. You need to find one that works on your car.. The one that Autozone uses for customers will work for your car.
  Reply With Quote
Old 09-11-2006, 13:11   #6 (permalink)
LouisvilleBird96
 
LouisvilleBird's Avatar
 
Join Date: Sep 2006
Location: Louisville, KY
Posts: 4
Re: "check engine ligth" ON

I have an issue. With the issue Temperature does not matter as far as I can tell for me...My car will start and if I have my foot on the gas it continues to run, but the moment I take it off it stalls. The car will not idle, and I have the shift to neutral when I arrive at a stop or a slow turn so with will not stall and lock up. I can smell the fuel burning rich.

I have checked fuses, all are fine. Just for the sake of mentioning the issue was going on before AND after the spark plugs and serpentine belt were replaced.

The "Check engine" light has been on for years, and I had the car checked when it first came on at the Ford Dealer, but they said nothing was wrong.
LouisvilleBird is offline   Reply With Quote
Old 09-17-2006, 15:26   #7 (permalink)
Registered User
 
Join Date: Jun 2006
Location: OH
Posts: 52
Re: "check engine ligth" ON

IAC or TPS for the stalling issue. Could also be a dirty MAF. As far as the codes go, the CEL won't come on if there's no codes present. Just to be sure, disconnect the battery for a few minutes. This will reset the computer. Then just wait and see if the CEL comes back on. If and when it does, take the car to a shop or AutoZone and have them scan the codes for you.
__________________
94 Thunderbird LX
fold_em83 is offline   Reply With Quote
Old 10-09-2006, 18:42   #8 (permalink)
Registered User
 
Join Date: Feb 2006
Posts: 25
Re: "check engine ligth" ON

I hade the same issue. it turned out to be the O2 sensors.

My mechanic said so many things trip those it is sometimes hard to locate it till the actual item fails and produces a code. This can drive anyone nuts.

Hope this helps.
72tbird is offline   Reply With Quote
Old 11-09-2006, 20:08   #9 (permalink)
Registered User
 
Join Date: Nov 2006
Posts: 1
Re: "check engine ligth" ON

My '96 Thunderbird's check engine light has been on since '99, no one can seem to fix it but the car still runs good. The codes are for O2 sensors but could be caused by other things not working correctly.

As for the won't idle and stalls at the light when you take your foot off the gas problem... I had the exact same problem. I tried cleaning the IAC (idle air control) unit and it still wouldn't idle. I bought a new one for about $72 and the engine has been running fine ever since! If you're unfamiliar with the IAC it's on the side of the throttle body with a 3/4" rubber hose running to it from the intake duct. Have fun.
GT4me is offline   Reply With Quote
Old 12-06-2006, 16:21   #10 (permalink)
Registered User
 
gearhead_ryan's Avatar
 
Join Date: Nov 2006
Location: Morehead, KY
Age: 25
Posts: 11
Re: "check engine ligth" ON

mine has the Malfunction indicator lamp on, i hooked mine up to a Scan tool and told me it had to do with the EGR valve, about how hard is it to change one of them out?
__________________
MY RIDES:

1995 Ford Thunderbird LX
4.6L V8 281ci
automatic

1994 Ford Mustang GT
5.0L V8 302ci HO
5-speed
gearhead_ryan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Thunderbird Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford's SuperCooler uses cold air to heat up engine performance Stacy94PGT Ford Worldwide News 1 04-05-2006 05:34
US: Ford 2005 Model Line-up From A to V Stacy94PGT Ford Worldwide News 2 09-21-2004 22:11
99 Sable , oil pressure loss PHF Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 0 07-10-2004 04:09
Territory Launch (Comprehensive) RPO83 Territory 25 05-03-2004 04:56
United States:Ford V-6 engine to be built in Ohio Stacy94PGT Ford Worldwide News 6 07-23-2003 21:42

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.